summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Sferrazza2017-10-16 22:06:48 -0400
committerKyle Sferrazza2017-10-16 22:06:48 -0400
commit66ad4408018bf524e62c252a9d43961791302a50 (patch)
treec07c4f8c86123256e9a43ea054d3774857b4ec15 /PKGBUILD
parent4cf771a38b21b67e610e535b4282c80080dd7c90 (diff)
downloadaur-openface-git.tar.gz
add two missing deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 23 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d05f57d0032f..4f9fd24cee55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,30 @@
pkgname='openface-git'
_pkgname='openface'
-pkgver="ac4ded4"
+pkgver='ac4ded4'
pkgrel=1
-pkgdesc="Face recognition with deep neural networks."
+pkgdesc='Face recognition with deep neural networks.'
arch=('x86_64')
-url="http://cmusatyalab.github.io/openface/"
-license=("Apache")
-depends=("graphicsmagick"
- "openssl"
- "libffi"
- "python"
- "python-pip"
- "python-numpy"
- "python-nose"
- "python-scipy"
- "python-pandas"
- "python-protobuf"
- "python-sslib"
- "wget"
- "zip")
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=($_pkgname::"git+https://github.com/cmusatyalab/openface")
+url='http://cmusatyalab.github.io/openface/'
+license=('Apache')
+depends=('graphicsmagick'
+ 'openssl'
+ 'libffi'
+ 'python'
+ 'python-pip'
+ 'python-numpy'
+ 'python-nose'
+ 'python-scipy'
+ 'python-pandas'
+ 'python-protobuf'
+ 'python-sslib'
+ 'wget'
+ 'zip'
+ 'python-dlib'
+ 'opencv')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=($_pkgname::'git+https://github.com/cmusatyalab/openface')
md5sums=('SKIP')
pkgver() {
@@ -36,7 +38,7 @@ build() {
./models/get-models.sh
mkdir -p build
- python2 setup.py install --root="$srcdir/$_pkgname/build/"
+ python setup.py install --root="$srcdir/$_pkgname/build/"
}
package() {