summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2021-07-01 12:10:09 +0200
committerbartus2021-07-01 12:10:52 +0200
commit044360953c1dad0325e8b90108f57fe286bfbb5e (patch)
treed967b23332bf9af521e09f59cb2c1400b77eaeac /PKGBUILD
parent751b16099ed40637d00a64e1262aed427e17d3a9 (diff)
downloadaur-044360953c1dad0325e8b90108f57fe286bfbb5e.tar.gz
Drop cereal osi_cpl submodule
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6ef60f8ad2c..ee5e6d79eb9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,27 +12,24 @@ arch=('i686' 'x86_64')
url='http://imagine.enpc.fr/~moulonp/openMVG/'
license=('MPL')
options=('!emptydirs')
-depends=('glfw' 'lz4' 'libpng' 'libjpeg' 'libtiff' 'libxcursor' 'libxinerama' 'libxrandr' 'libxxf86vm' 'libxi' 'graphviz' 'libgl' 'ceres-solver' 'gflags' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-osi' 'coin-or-lemon')
+depends=(qt5-{base,svg} 'cereal' 'glfw' 'lz4' 'libpng' 'libjpeg' 'libtiff' 'libxcursor' 'libxinerama' 'libxrandr' 'libxxf86vm' 'libxi' 'graphviz' 'libgl' 'ceres-solver' 'gflags' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-osi' 'coin-or-lemon')
makedepends=('git' 'cmake' 'doxygen' 'eigen')
source=("git+https://github.com/${_gitname}/${_gitname}.git${_fragment}"
'git+https://github.com/elmindreda/glfw.git'
- 'git+https://github.com/openMVG-thirdparty/osi_clp.git'
- 'git+https://github.com/openMVG-thirdparty/cereal.git'
'findflann-v0.1.patch'
'ld_ceres.patch::https://github.com/openMVG/openMVG/pull/1831.patch'
+ 'submodule.patch'
)
sha256sums=('SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
'13b1f0195b5e97c17eec737e63f4da69c501bb4ced28c4c14517440009139043'
- '53e5211b55af6f1feabff8962c174227a68e7129f97c4624c05fe1cbca428f43')
+ '53e5211b55af6f1feabff8962c174227a68e7129f97c4624c05fe1cbca428f43'
+ '5dcde15464d0b457f0149fff2088f33e59f9c43a2aba9d2351538a0a5fce739d')
b2sums=('SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
'f70e6c4d3368d170d8c182511e1b2ee9aa76ff6495fee6f50fcfbcc432f2c330d4c84868a536df605e0c630b81d024ac0bdd48124d7ad1c4f8ff9114a1850854'
- '1ce09655750be003ea029be943e8382b0ca9512263bddd28b3536a73e18e071ea4d12de250a75c412649f129b58edbdc6c17302b760173cf338c194ad4b78251')
+ '1ce09655750be003ea029be943e8382b0ca9512263bddd28b3536a73e18e071ea4d12de250a75c412649f129b58edbdc6c17302b760173cf338c194ad4b78251'
+ '688cd6f2ce02448bd75001c509b68f9265496abf0c6b00a46c373e3a6c337f5e24d4d6d3ce8cec3801fd823a076f1de68733edb0ae0283920aea16889c4299e1')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -42,10 +39,8 @@ pkgver() {
prepare() {
cd "${srcdir}/${_gitname}"
git config 'submodule.src/dependencies/glfw.url' "${srcdir}/glfw"
- git config 'submodule.src/dependencies/osi_clp.url' "${srcdir}/osi_clp"
- git config 'submodule.src/dependencies/cereal.url' "${srcdir}/cereal"
- git submodule update --init --remote
- git apply ${srcdir}/{findflann-v0.1,ld_ceres}.patch
+ git submodule update --init --remote src/dependencies/glfw
+ git apply "${srcdir}"/{findflann-v0.1,ld_ceres,submodule}.patch
}
build() {