summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2018-03-28 22:22:34 +0200
committerbartus2018-03-28 22:26:36 +0200
commit2260069712b319d475e782e72203f7ab20a75849 (patch)
tree4a42fa79124d28ec426132ed958cae127b5bb70e /PKGBUILD
parent59658287e34bec8d126a2c5cdaaeaae2489c1582 (diff)
downloadaur-2260069712b319d475e782e72203f7ab20a75849.tar.gz
fix library issue, switch to branch develop
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fbfa6a2490a..a8ac075c84c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
# Maintainer: Kyle Brooks <brookskd@gmail.com>
+# update: bartus <aur\at/bartus.33mail.com>
pkgname=openmvg-git
-pkgver=1.0.r0.g944254c
-pkgrel=4
+_gitname='openMVG'
+_fragment="#branch=develop"
+pkgver=1.3.r55.g01cb080b
+pkgrel=5
pkgdesc='open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.'
arch=('i686' 'x86_64')
url='http://imagine.enpc.fr/~moulonp/openMVG/'
license=('MPL')
-depends=('libpng' 'libjpeg' 'libtiff' 'libxrandr' 'libxxf86vm' 'libxi' 'graphviz' 'libgl' 'ceres-solver' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-osi' 'coin-or-lemon')
+depends=('lz4' 'libpng' 'libjpeg' 'libtiff' 'libxrandr' 'libxxf86vm' 'libxi' 'graphviz' 'libgl' 'ceres-solver' 'gflags' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-osi' 'coin-or-lemon')
makedepends=('git' 'cmake' 'doxygen' 'eigen')
-_gitname='openMVG'
-source=("git+https://github.com/openMVG/${_gitname}.git"
+source=("git+https://github.com/${_gitname}/${_gitname}.git${_fragment}"
'git+https://github.com/elmindreda/glfw.git'
'git+https://github.com/openMVG-thirdparty/osi_clp.git'
'git+https://github.com/openMVG-thirdparty/cereal.git'
- 'libopenMVG_sfm_link_error.patch'
+ 'fast.patch'
+ 'lemon.patch'
+ 'flann.patch'
)
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '8e1dd6742b2ed87b1086829e75d69cee'
- )
+ 'c2fff3b04a2444a635eab1709be6b4f2'
+ '11aa728e50e52b10d79dd83dfaa6c1c6'
+ '91e8cb2e3b2449de83dd49c83359b8ab')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -34,14 +39,17 @@ prepare() {
git config 'submodule.src/dependencies/osi_clp.url' "${srcdir}/osi_clp"
git config 'submodule.src/dependencies/cereal.url' "${srcdir}/cereal"
git submodule update
- git apply ../libopenMVG_sfm_link_error.patch
+ git apply ${srcdir}/lemon.patch
+ git apply ${srcdir}/fast.patch
+ git apply ${srcdir}/flann.patch
+ cp src/third_party/flann/cmake/FindFlann.cmake src/cmakeFindModules/
}
build() {
cd "${srcdir}"
mkdir -p openmvg_build
cd openmvg_build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE -DOpenMVG_BUILD_SHARED=ON -DOpenMVG_BUILD_EXAMPLES=ON -DOpenMVG_BUILD_DOC=ON -DOpenMVG_BUILD_OPENGL_EXAMPLES=ON -DOpenMVG_USE_OPENMP=ON -DFLANN_INCLUDE_DIR_HINTS=/usr/include -DCOINUTILS_INCLUDE_DIR_HINTS=/usr/include/coin -DCLP_INCLUDE_DIR_HINTS=/usr/include/coin -DOSI_INCLUDE_DIR_HINTS=/usr/include/coin -DLEMON_INCLUDE_DIR_HINTS=/usr/include -DCERES_DIR_HINTS=/usr/share/Ceres -DEIGEN_INCLUDE_DIR_HINTS=/usr/include/eigen3 ../openMVG/src/
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE -DOpenMVG_BUILD_SHARED=ON -DOpenMVG_BUILD_EXAMPLES=ON -DOpenMVG_BUILD_OPENGL_EXAMPLES=ON -DOpenMVG_USE_OPENMP=ON -DFLANN_INCLUDE_DIR_HINTS=/usr/include -DCOINUTILS_INCLUDE_DIR_HINTS=/usr/include/coin -DCLP_INCLUDE_DIR_HINTS=/usr/include/coin -DOSI_INCLUDE_DIR_HINTS=/usr/include/coin -DLEMON_INCLUDE_DIR_HINTS=/usr/include/lemon -DCERES_DIR_HINTS=/usr/include/ceres -DEIGEN_INCLUDE_DIR_HINTS=/usr/include/eigen3 ../openMVG/src/
make
}