summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2018-07-15 14:42:18 +0200
committerbartus2018-07-15 14:42:18 +0200
commit8691aa83920adcb0402c0d21172068a9a2c7389c (patch)
treef190abfdd9a8923866ea526d00a546bbfeaa43a2 /PKGBUILD
parent2e7da5112739d5629ad61d7f66ab368d6bc4dba7 (diff)
downloadaur-8691aa83920adcb0402c0d21172068a9a2c7389c.tar.gz
remove upstream included paches
fix stlplus library linking target in VO and SfMViewer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c968e6edfae..d279d5ed6ef9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=openmvg-git
_gitname='openMVG'
_fragment="#branch=develop"
-pkgver=1.3.r91.g4c7367cd
+pkgver=1.3.r115.g903b2f44
pkgrel=1
pkgdesc='open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.'
arch=('i686' 'x86_64')
@@ -16,17 +16,15 @@ source=("git+https://github.com/${_gitname}/${_gitname}.git${_fragment}"
'git+https://github.com/elmindreda/glfw.git'
'git+https://github.com/openMVG-thirdparty/osi_clp.git'
'git+https://github.com/openMVG-thirdparty/cereal.git'
- 'lemon.patch'
'findflann-v0.1.patch'
- 'evalquality.patch'
+ 'stlplus.patch'
)
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '11aa728e50e52b10d79dd83dfaa6c1c6'
'f421cb25208a4f95784035d9823abe04'
- 'e3ffb7463245b92fdee08045715640ab')
+ '45325ddb7a710f79e619ba2085697833')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -40,9 +38,10 @@ prepare() {
git config 'submodule.src/dependencies/osi_clp.url' "${srcdir}/osi_clp"
git config 'submodule.src/dependencies/cereal.url' "${srcdir}/cereal"
git submodule update
- git apply ${srcdir}/lemon.patch
+ msg "flann patch"
git apply ${srcdir}/findflann-v0.1.patch
- git apply ${srcdir}/evalquality.patch
+ msg "fix link target missing stlplus library"
+ git apply ${srcdir}/stlplus.patch
}
build() {