summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-04-12 22:15:56 +0800
committerChocobo12023-04-12 22:15:56 +0800
commit531fe561a9205e45fc7466b1c0bb46690963a9ff (patch)
tree7d52c799a245c5b020ad4d76f1acf813217b3a88 /PKGBUILD
parent3addfdb5bf23c399cdc496209d3def47a9decf82 (diff)
downloadaur-openresolv-git.tar.gz
upgpkg: openresolv-git 3.12.0.r5.g24d2882-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2593c309f2f2..09568f55cb07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=openresolv-git
-pkgver=3.9.0.r7.g133d6b3
+pkgver=3.12.0.r5.g24d2882
pkgrel=1
pkgdesc="The DNS management framework"
arch=('any')
@@ -9,10 +9,10 @@ url="https://roy.marples.name/projects/openresolv"
license=('BSD')
depends=('sh')
makedepends=('git')
-provides=('openresolv')
+provides=("openresolv=$pkgver")
conflicts=('openresolv')
backup=('etc/resolvconf.conf')
-source=("git+https://roy.marples.name/git/openresolv.git")
+source=("git+https://github.com/NetworkConfiguration/openresolv.git")
sha256sums=('SKIP')
@@ -25,8 +25,11 @@ pkgver() {
build() {
cd "openresolv"
- ./configure --prefix="/usr" --sysconfdir="/etc" \
- --sbindir="/usr/bin" --libexecdir="/usr/lib/resolvconf"
+ ./configure \
+ --prefix="/usr" \
+ --sysconfdir="/etc" \
+ --sbindir="/usr/bin" \
+ --libexecdir="/usr/lib/resolvconf"
make
}
@@ -34,5 +37,5 @@ package() {
cd "openresolv"
make DESTDIR="$pkgdir" install
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/openresolv/LICENSE"
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/openresolv"
}