summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormaisvendoo2018-11-01 21:19:41 +0300
committermaisvendoo2018-11-01 21:19:41 +0300
commit19186eda52585d1b03574efc8f375015aba18fe0 (patch)
tree62ea5fec5c916e090ae534c1fe25733184a6e4bf /PKGBUILD
downloadaur-openscenegraph-dev.tar.gz
Package ready
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65190cf11c8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: maisvendoo <maisvendoo@gmail.com>
+# Contributor: jmf <jmf at mesecons dot net>
+
+pkgname=openscenegraph-dev
+pkgver=3.7.0
+_pkgver=3.7.0
+pkgrel=1
+pkgdesc="Development version of open source, high performance real-time graphics toolkit OpenSceneGraph"
+arch=('x86_64')
+url="http://www.openscenegraph.org"
+license=('custom:OSGPL')
+depends=('giflib' 'jasper' 'librsvg' 'xine-lib' 'curl' 'pth')
+makedepends=('cmake' 'libvncserver' 'qt5-base' 'ffmpeg' 'mesa')
+optdepends=('libvncserver' 'gdal' 'openexr' 'poppler-glib' 'qt5-base' 'ffmpeg')
+provides=('openscenegraph' 'openthreads')
+conflicts=('openscenegraph' 'openthreads')
+source=("openscenegraph::git+https://github.com/openscenegraph/OpenSceneGraph.git#branch=master")
+sha256sums=('SKIP')
+options=(!strip)
+
+prepare() {
+ mkdir -p "${srcdir}/build-debug"
+ mkdir -p "${srcdir}/build-release"
+}
+
+build() {
+ cd "${srcdir}/build-debug"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIBRARY_OUTPUT_PATH=/usr/lib \
+ -DCMAKE_BUILD_TYPE=Debug ../openscenegraph
+
+ make -j8
+
+ cd "${srcdir}/build-release"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIBRARY_OUTPUT_PATH=/usr/lib \
+ -DCMAKE_BUILD_TYPE=Release ../openscenegraph
+
+ make -j8
+}
+
+package(){
+ cd "${srcdir}/build-debug"
+ make DESTDIR="$pkgdir" install
+
+ cd "${srcdir}/build-release"
+ make DESTDIR="$pkgdir" install
+
+ mv "${pkgdir}/usr/lib64" "${pkgdir}/usr/lib"
+}