summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2014-08-06 13:01:02 +0200
committerCarsten Teibes2014-08-06 13:01:02 +0200
commit6b6e31a7f9dcd45c218f3fffff206a303463f537 (patch)
treec3255c644837e9aa50f8e03aef50940fc73510bf /PKGBUILD
parent02435e48ee0cf90eaf78b856bf58e787b05da5a4 (diff)
downloadaur-opensonic.tar.gz
Remove libpng fix, not needed after allegro4 rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2336ad20281e..caf37b35943e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Anton Larionov <diffident dot cat at gmail dot com>
# Contributor: Dany Martineau <dany.luc.martineau gmail com>
# Contributor: Tom Boshoven <tomboshoven at gmail dot com>
@@ -15,25 +15,17 @@ makedepends=('cmake')
install=opensonic.install
source=("http://downloads.sourceforge.net/project/opensnc/Open%20Sonic/$pkgver/opensnc-src-$pkgver.tar.gz"
"$pkgname.desktop"
- "$pkgname.sh"
- "http://arch.carsten-teibes.de/aur-stuff/$pkgname-loadpng.tar.xz")
+ "$pkgname.sh")
sha256sums=('3a4c3fa9538ee27c04b5ea848c9ad0a83f335471936d4617a18d3648c42588e9'
'8649e72ba9eb3e01da81671c9c849a6823ccd4f022819e8b57d24abdaa691b06'
- 'a7ed81118fea52c8ce60a8538e92b6121da3b3358c41d1e6d370ada83cef8740'
- '9681cf2519b5217149dababbc67ae0280d454a59b3b46ec36c0c9e843a554e36')
+ 'a7ed81118fea52c8ce60a8538e92b6121da3b3358c41d1e6d370ada83cef8740')
build() {
- cd loadpng
- cmake .
- make
+ cd opensnc-src-$pkgver
- cd ../opensnc-src-$pkgver
- # add folder of loadpng.a (extracted from configure script)
- export _ALLEGRO_LIBS="-L$srcdir/loadpng $(allegro-config --libs)"
- export _ALLEGRO_VERSION="$(allegro-config --version)"
# fix broken linking
export LDFLAGS="$LDFLAGS -Wl,--no-as-needed"
- cmake .
+ ./configure
make
}