summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsmls2016-05-29 22:13:33 +0200
committersmls2016-05-29 22:13:33 +0200
commit0254e9ccd14f36b950a86beec7cc4d53618e206b (patch)
treec29be87f2dd566df068f9f7908c283a0ab7b2ca1 /PKGBUILD
parent5149259a5bd85ac8204385e7272ec7942c8d2ac7 (diff)
downloadaur-openttd-opengfx-snapshot.tar.gz
bump version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a660bdd6d393..2828d786e120 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Inspired by the netbeans-nightly PKGBUILD by Pavol Hluchy (Lopo) <lopo at losys dot eu>
pkgname=openttd-opengfx-snapshot
-pkgver=0.5.4+s20160110
+pkgver=0.5.4+s20160505
pkgrel=1
pkgdesc='A free graphics set for openttd (latest snapshot release)'
arch=('any')
@@ -14,8 +14,6 @@ _webroot="http://bundles.openttdcoop.org/opengfx/nightlies/LATEST/"
pkgver() {
cd "${SRCDEST}"
- rm -f changelog.txt && download_file "${_webroot}/changelog.txt"
- rm -f custom_tags.txt && download_file "${_webroot}/custom_tags.txt"
_lastrelease="$(grep -Pom1 'OpenGFX\s+\K[^\s]+' changelog.txt)"
_snapshotdate="$(grep -Po '^VERSION_STRING.*?:\K[0-9-]+' custom_tags.txt |
@@ -26,6 +24,10 @@ pkgver() {
prepare() {
cd "${SRCDEST}"
+
+ rm -f changelog.txt && download_file "${_webroot}/changelog.txt"
+ rm -f custom_tags.txt && download_file "${_webroot}/custom_tags.txt"
+
_snapshotnum="$(grep -Po '^NEWGRF_VERSION.*?:\K.*' custom_tags.txt)"
_file="opengfx-v${_snapshotnum}"
msg2 "${_webroot}/${_file}.zip"