summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2024-04-25 19:35:31 -0300
committerDaniel Bermond2024-04-25 19:35:31 -0300
commit44ca29fafdc25e9aa634af0146fe1b3b89edf09a (patch)
tree928a62889319b4b24bbdde76351823dcca761e98 /PKGBUILD
parentae1d113bb317db6e228af78549914c5ee1a18bfd (diff)
downloadaur-openvino.tar.gz
Update to version 2024.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e9fb1daf09e..1db2804029bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://github.com/openvinotoolkit/openvino/issues/452#issuecomment-722941119
pkgname=openvino
-pkgver=2024.0.0
+pkgver=2024.1.0
pkgrel=1
pkgdesc='A toolkit for developing artificial inteligence and deep learning applications'
arch=('x86_64')
@@ -47,11 +47,17 @@ source=("git+https://github.com/openvinotoolkit/openvino.git#tag=${pkgver}"
'git+https://github.com/google/snappy.git'
'git+https://github.com/ARM-software/ComputeLibrary.git'
'git+https://github.com/openvinotoolkit/mlas.git'
+ 'git+https://github.com/oneapi-src/level-zero.git'
+ 'git+https://github.com/intel/level-zero-npu-extensions.git'
+ 'git+https://github.com/openvinotoolkit/telemetry.git'
'openvino.conf'
'setupvars.sh'
'010-openvino-disable-werror.patch'
'020-openvino-use-protobuf-shared-libs.patch')
-sha256sums=('SKIP'
+sha256sums=('edf2a719de99981396784da9e42483a16c8a2e24453780693cc69d452b4b45b3'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP'
'SKIP'
'SKIP'
@@ -75,8 +81,8 @@ sha256sums=('SKIP'
'SKIP'
'335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af'
'e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c'
- '1b420e3cc2afca11154c672123f001cf03cd2b96be3baafd229f6ee7d752419e'
- '17417f7193e94c7df32242c71d650d8beda2dadea8b05db131a7731a56e9c84a')
+ '0bbf46bef304dea08b318d1ffd564735b19e1afb6c0f41c98d216824cc630132'
+ '2329bb09c80ce44ae622da9d318d246b237e3a4d259d12f6b8920a249ec994bb')
export GIT_LFS_SKIP_SMUDGE='1'
@@ -106,6 +112,9 @@ prepare() {
git -C openvino config --local submodule.thirdparty/snappy.url "${srcdir}/snappy"
git -C openvino config --local submodule.ARMComputeLibrary.url "${srcdir}/ComputeLibrary"
git -C openvino config --local submodule.src/plugins/intel_cpu/thirdparty/mlas.url "${srcdir}/mlas"
+ git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero.url "${srcdir}/level-zero"
+ git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero-ext.url "${srcdir}/level-zero-npu-extensions"
+ git -C openvino config --local submodule.thirdparty/telemetry.url "${srcdir}/telemetry"
git -C openvino -c protocol.file.allow='always' submodule update
patch -d openvino -Np1 -i "${srcdir}/010-openvino-disable-werror.patch"