summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor de Jong2024-10-11 22:35:40 +0200
committerVictor de Jong2024-10-11 22:35:40 +0200
commit9fcc96d0de7d8f0816b8814f8ea2dadff63ec3d6 (patch)
tree1f401d332ed26f04b2feea10f6ec517ff52b1bf8 /PKGBUILD
parent777fb29c033269f2c4fea8647800c0e56d33eb2d (diff)
downloadaur-openvpn-nl.tar.gz
Bump package to new release 2.5.11nl1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5afc688bb86c..f4e5df9aeb0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Victor de Jong <victor@victordejong.com>
pkgname=openvpn-nl
-pkgver=2.5.10nl1
+pkgver=2.5.11nl1
pkgrel=1
pkgdesc="An open-source fork of OpenVPN for use by the NL government up to Dep.V."
arch=('x86_64')
@@ -9,16 +9,16 @@ license=('GPL-2.0-only')
depends=('systemd-libs' 'glibc' 'perl' 'sh' 'bash')
makedepends=('gnupg')
source=(
- "https://openvpn.fox-it.com/repos/deb/dists/jammy/Release"
- "https://openvpn.fox-it.com/repos/deb/dists/jammy/Release.gpg"
- "https://openvpn.fox-it.com/repos/deb/dists/jammy/main/binary-amd64/Packages"
- "https://openvpn.fox-it.com/repos/deb/pool/main/o/${pkgname}/${pkgname}_${pkgver::-3}-nl1-jammy_amd64.deb"
+ "https://openvpn.fox-it.com/repos/deb/dists/noble/Release"
+ "https://openvpn.fox-it.com/repos/deb/dists/noble/Release.gpg"
+ "https://openvpn.fox-it.com/repos/deb/dists/noble/main/binary-amd64/Packages"
+ "https://openvpn.fox-it.com/repos/deb/pool/main/o/${pkgname}/${pkgname}_${pkgver::-3}-nl1-noble_amd64.deb"
)
sha512sums=(
- 'd899f46ffc50ba56a8b523970b24a3189a34cc5422c8dbfe10a0fe3590927ed3275b777862d82e190fbe7cda31f77570d316bd06bf5c79ec7ffe93a86a2e98d9'
- 'accdb4f55e2d8b0ad6d0a8e80f3ae4c646295bf733165eeda765b166ef7019709f3ecfaca041e39988bdb6265c62bb9f4a268608f5f03ea473682a3f827d8703'
- '2544a077aea8e03164ecdc02a0ef9dd1ce8c3a1ea1f037e2f2d76c729e21b20b60515421e9f29ccb68aafb4060ff386c48e990c998831fb61c07eb24155fabb0'
- '66b537ceaf927618946687ba593429c7820887ff248037d5ed768f62f9d59d6142f2f73b7d1532473469451b2d39f599955616ac5cd971928913fd307752ba5d'
+ '0ed457e0a71f9bf96f639345e0c48b59be1ac633fa68862dc6ae8ca732144267efbeba84c7a9d403b05d51136658fb19ff4881790e570e3c6820513032625ab4'
+ '83deac5fc56fd68fcc907325bbc0ed30bbc532041f7f547220bfb07e27d921d3bbb11ecff3ff9256ba6d64cf194bd2f427d2ebe1ba7c05f1aa8f9dd2b70898ad'
+ '242c8af0fc2e13443b5e7bd3cc185184bcc916a03b162396c2fc27f423239968b02d04d67dd985f1e72c3f3b532a844ad100a1226432b329537da7088843a4ed'
+ 'd321d20c2b80c8692f8a4cbe3e67706041738a5079f0fef0f191cdf574edc1ea835545c731ff8ee9e9d2e8dbcb88cb5e315afc3de40ecfa3c25b0f9c754ca764'
)
validpgpkeys=('A518F75374D3AF82AE11810A13DF39ED913F5D8F')
@@ -31,8 +31,8 @@ prepare() {
gpg --verify Release.gpg Release || (echo -e "${_RED}There is something wrong with the signature! Either this package is compromised or you need to import the key from https://openvpn.fox-it.com/repos/fox-crypto-gpg.asc${_NC}" && exit 1)
echo -e "${_YEL}Verifying Packages file with previously verified Release file...${_NC}"
(sed -n 17p Release | awk '{print $1 " Packages"}' | sha256sum --check --status --strict && echo "OK") || (echo -e "${_RED}There is something wrong with the SHA256 hash! This package is likely compromised and should not be used!${_NC}" && exit 1)
- echo -e "${_YEL}Verifying ${pkgname}_${pkgver::-3}-nl1-jammy_amd64.deb package with previously verified Packages file...${_NC}"
- (sed -n 12p Packages | awk -v name=${pkgname}_${pkgver::-3}-nl1-jammy_amd64.deb '{print $2 " " name}' | sha256sum --check --status --strict && echo "OK") || (echo -e "${_RED}There is something wrong with the SHA256 hash! This package is likely compromised and should not be used!${_NC}" && exit 1)
+ echo -e "${_YEL}Verifying ${pkgname}_${pkgver::-3}-nl1-noble_amd64.deb package with previously verified Packages file...${_NC}"
+ (sed -n 12p Packages | awk -v name=${pkgname}_${pkgver::-3}-nl1-noble_amd64.deb '{print $2 " " name}' | sha256sum --check --status --strict && echo "OK") || (echo -e "${_RED}There is something wrong with the SHA256 hash! This package is likely compromised and should not be used!${_NC}" && exit 1)
}
package() {
@@ -41,5 +41,4 @@ package() {
install -vDm755 ${srcdir}/usr/sbin/openvpn-nl ${pkgdir}/usr/bin/openvpn-nl
cp -r ${srcdir}/etc ${pkgdir}/etc
cp -r ${srcdir}/usr/share ${pkgdir}/usr/share
- cp -r ${srcdir}/lib/ ${pkgdir}/usr
}