summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora.kudelin2019-09-08 00:01:45 +0300
committera.kudelin2019-09-08 00:01:45 +0300
commite386c37661b7b3cc7d04a0c2b154eef89d680a8d (patch)
treec1758d32ffd556ae070402252273216259a827d5 /PKGBUILD
downloadaur-optionmatrix.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6084cfa869dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+
+pkgname=optionmatrix
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="A financial derivative calculator with 168+ models"
+arch=("x86_64")
+url="https://sourceforge.net/projects/optionmatrix"
+license=('GPL')
+depends=('gtk3' 'gsl')
+makedepends=('texlive-core')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz")
+sha256sums=('8dc04f9a8086ffd3aaa2b386f0cfb05ad69b651d8b6b926880325a78a3bba0fd')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make -k check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}