summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArgyros Argyridis2024-04-10 11:42:11 +0300
committerArgyros Argyridis2024-04-10 11:42:11 +0300
commit8a4f83c43153257a5d2069d4215c7dc2b5892d10 (patch)
tree703d1815161e05de9942b4adb6fe1a89b3f47519 /PKGBUILD
parent03a423881dab42a6dfc234dbdcfd9d56147f5dbb (diff)
downloadaur-orfeo-toolbox.tar.gz
fixing issues:
- Disabling shark-ml and learning flags for package to build - Added libkml as depedency - removed qt5-base from make depedencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79f27b295598..1ff03b09b726 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Argyros Argyridis <arargyridis@gmail.com>
# Contributor: Samuel Mesa <samuelmesa@linuxmail.org>
+# Contributor: Tu Yu-Hsuan <dobe0331@gmail.com>
pkgname=orfeo-toolbox
pkgver=9.0.0
_pkgver=9.0
-pkgrel=1
+pkgrel=2
pkgdesc="ORFEO Toolbox (OTB) is an open source library of image processing algorithms"
arch=(x86_64 i686)
url="http://www.orfeo-toolbox.org"
license=('CeCILL')
groups=()
-depends=('gdal' 'cblas' 'freeglut' 'curl' 'fftw' 'tinyxml' 'muparser' 'muparserx' 'python' 'boost' 'lapack' 'hdf5' 'insight-toolkit4' 'libsvm' 'opencv>=3' 'openmpi')
-makedepends=('git' 'swig' 'cmake' 'qt5-base')
+depends=('gdal' 'cblas' 'freeglut' 'curl' 'fftw' 'tinyxml' 'muparser' 'muparserx' 'python' 'boost' 'lapack' 'hdf5' 'insight-toolkit4' 'libsvm' 'opencv>=3' 'openmpi' 'libkml')
+makedepends=('git' 'swig' 'cmake')
optdepends=()
provides=()
conflicts=()
@@ -62,7 +63,7 @@ build() {
-DBUILD_SHARED_LIBS=ON \
-DOTBGroup_FeaturesExtraction=ON \
-DOTBGroup_Hyperspectral=ON \
- -DOTBGroup_Learning=ON \
+ -DOTBGroup_Learning=OFF \
-DOTBGroup_Miscellaneous=ON \
-DOTBGroup_Remote=ON \
-DOTBGroup_SAR=ON \