summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2024-04-19 22:26:06 +0200
committerJulian Xhokaxhiu2024-04-19 22:26:06 +0200
commit32c4d6d92e018dc0927bee7d3186b76e12f0df85 (patch)
treea37eb24819916ec03fea3fd111c3af72260105b5 /PKGBUILD
parentc1dc42fb4b7cba9ab4373658945ad397f08475dc (diff)
downloadaur-oscam-git.tar.gz
11767-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc995d94c8e2..6c58f166a267 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,19 @@
# Author: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
# Maintainer: Julian Xhokaxhiu <info@julianxhokaxhiu.com>
pkgname=oscam-git
-pkgver=11719
+pkgver=11767
pkgrel=1
pkgdesc="Open Source Conditional Access Module software"
url="http://www.streamboard.tv/oscam"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
license=('GPL3')
-depends=('libusb' 'openssl' 'pcsclite')
-makedepends=('subversion')
+depends=('libusb' 'openssl' 'pcsclite' 'libdvbcsa')
+makedepends=('git')
optdepends=('pcsclite: for use with PC/SC readers'
'ccid: PC/SC reader generic driver')
conflicts=('oscam-svn')
install='oscam.install'
-source=("$pkgname::svn+https://svn.streamboard.tv/oscam/trunk"
+source=("$pkgname::git+https://git.streamboard.tv/common/oscam.git"
'oscam.service'
'oscam.sysuser')
sha256sums=('SKIP'
@@ -25,7 +25,7 @@ sha256sums=('SKIP'
pkgver() {
cd "$pkgname"
- LANG=C svn info | grep '^Revision:' | sed -e 's/^Revision: //'
+ ./config.sh --oscam-revision
}
build() {
@@ -40,7 +40,6 @@ build() {
USE_PCSC=1 \
OSCAM_BIN=oscam \
LIST_SMARGO_BIN=list_smargo \
- SVN_REV=$pkgver \
EXTRA_CC_WARN=-w
}