summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVadim Yanitskiy2024-01-28 07:24:46 +0700
committerVadim Yanitskiy2024-01-28 07:24:46 +0700
commit0c092cf2fcb5afdb8edf20b135827f63983ba946 (patch)
tree2e06387c17dfea055ccc0a56ef6760895801857a /PKGBUILD
parentb9ada27d23b9e8446101651274623f9704cf91ca (diff)
downloadaur-osmo-sip-connector-git.tar.gz
update $pkgver, $source; fix $depends; drop $provides
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48f8ed0002fd..e2febc907dfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: Josef Miegl <josef@miegl.cz>
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+# Contributor: Josef Miegl <josef@miegl.cz>
pkgname=osmo-sip-connector-git
-pkgver=1.2.0.r0.g336add4
+pkgver=1.6.3.r6.g6122400
pkgrel=1
pkgdesc="Gateway between the MNCC Interface of OsmoMSC and OsmoNITB and an external SIP trunk"
url="https://osmocom.org/projects/osmo-sip-conector"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
-depends=('libosmocore' 'talloc' 'libosmo-abis' 'sofia-sip-bc')
+depends=('libosmocore' 'talloc' 'sofia-sip')
makedepends=('git')
-provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=('etc/osmocom/osmo-sip-connector.cfg')
-source=("git+https://git.osmocom.org/${pkgname%-git}")
+source=("git+https://gitea.osmocom.org/cellular-infrastructure/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
@@ -27,7 +27,9 @@ prepare() {
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
make
}