summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVadim Yanitskiy2024-01-20 17:25:41 +0700
committerVadim Yanitskiy2024-01-28 08:04:22 +0700
commit1f3f3e3726b43d2b6f337a1f310ccf769416d9c2 (patch)
tree2c9e5f4fa8af71801ff6a81c8dba74ce1a039175 /PKGBUILD
parentb52844c746c2797d0c97cef5ea02740468f1695c (diff)
downloadaur-osmo-trx-git.tar.gz
update $pkgver, $backup, $source; drop 'gnuradio' dep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 21 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b300fc6c9f1e..dfde1eceada8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,25 @@
-# Maintainer: Josef Miegl <josef@miegl.cz>
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+# Contributor: Josef Miegl <josef@miegl.cz>
pkgname=osmo-trx-git
-pkgver=1.0.0.r5.g158ea5b
+pkgver=1.6.0.r9.ga118d98e
pkgrel=1
pkgdesc="GSM Radio Modem based on a fork of the OpenBTS Transceiver program"
url="https://osmocom.org/projects/osmotrx"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
-depends=('libosmocore' 'talloc' 'libusb' 'fftw' 'libuhd' 'limesuite')
+depends=('libosmocore'
+ 'libusb'
+ 'libuhd' # --with-uhd
+ 'limesuite' # --with-lms
+ 'talloc'
+ 'fftw')
makedepends=('git' 'boost')
-optdepends=('gnuradio: legacy support for USRP1')
-provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-backup=('etc/osmocom/osmo-trx-lms.cfg' 'etc/osmocom/osmo-trx-uhd.cfg')
-source=("git+https://git.osmocom.org/${pkgname%-git}")
+backup=('etc/osmocom/osmo-trx-uhd.cfg'
+ 'etc/osmocom/osmo-trx-lms.cfg'
+ 'etc/osmocom/osmo-trx-ipc.cfg')
+source=("git+https://gitea.osmocom.org/cellular-infrastructure/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
@@ -28,7 +34,14 @@ prepare() {
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-uhd --with-lms
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-uhd \
+ --with-lms \
+ --with-ipc
+ # --enable-mstrx
+ # --with-bladerf
make
}