summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-08-19 15:01:13 -0500
committerLuis Martinez2021-08-19 15:01:13 -0500
commit630c44ff259424b42674271177907329d28f176f (patch)
tree791f27c5dbadeed67cc828af47f9b22ea4ba749f /PKGBUILD
parentbe72efc0f00b46ea53ab4a78098a5439bcad09b7 (diff)
downloadaur-otf-aileron.tar.gz
fix package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bae0d6e1f050..3e74f54126ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,19 @@
-# Maintainer: Orffen <orffen@orffenspace.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Orffen <orffen@orffenspace.com>
+
pkgname=otf-aileron
pkgver=0.102
-pkgrel=3
+pkgrel=4
pkgdesc="A grotesque sans-serif font by dot colon."
arch=('any')
-url="http://dotcolon.net/font/aileron/"
+url="https://dotcolon.net/font/aileron/"
license=('custom:CC0')
-provides=('otf-aileron')
-source=('http://dotcolon.net/DL/font/aileron.zip'
- 'http://creativecommons.org/publicdomain/zero/1.0/legalcode.txt')
+source=("$pkgname-$pkgver.zip::https://dotcolon.net/download/fonts/aileron_0102.zip"
+ "LICENSE.txt::https://creativecommons.org/publicdomain/zero/1.0/legalcode.txt")
sha256sums=('a93a1327f44912a7b1410ad0056fec3e904074413b0bd9da550f6175587cf958'
'a2010f343487d3f7618affe54f789f5487602331c0a8d03f49e9a7c547cf0499')
package() {
-
- install -D -m644 legalcode.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
-
- install -d "${pkgdir}/usr/share/fonts/OTF/"
- install -m644 Aileron-*.otf "${pkgdir}/usr/share/fonts/OTF/"
+ install -Dm 644 Aileron-*.otf -t "$pkgdir/usr/share/fonts/OTF/"
+ install -Dm 644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
}
-