summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKokaKiwi2019-08-22 00:09:29 +0200
committerKokaKiwi2019-08-22 00:09:29 +0200
commitb6648d0bdb6c492c05db1d174b09175cd869e740 (patch)
treeb17e234ce9b2d602c4cf0fbeec6b6e815cf1d3d0 /PKGBUILD
downloadaur-otf-brass-mono.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ba1d84f0e69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: KokaKiwi <kokakiwi+aur@kokakiwi.net>
+
+pkgname=otf-brass-mono
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="Retro monospaced font inspired by 70's design."
+arch=('any')
+url='https://github.com/fonsecapeter/brass_mono'
+license=('custom:OLF')
+depends=()
+source=("${pkgname}-${pkgver}.zip::https://github.com/fonsecapeter/brass_mono/releases/download/v${pkgver}/BrassMono.zip")
+sha512sums=('0c145da9d225e25437e8971a837bdde9b62e564e907b144de759f766c110a7a12101915c6d74837cb3c97a7a66e1db7a2185193da9c723a186dd3d834d566fcc')
+
+package() {
+ cd "BrassMono"
+
+ # Install fonts
+ install -dm0755 "${pkgdir}"/usr/share/fonts/OTF
+
+ for font in *.otf; do
+ install -m0644 $font "${pkgdir}"/usr/share/fonts/OTF/BrassMono-"${font/_/-}"
+ done
+
+ # Install license
+ install -Dm0644 LICENSE.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}