aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPedro Henrique2018-12-22 00:41:32 -0300
committerPedro Henrique2018-12-22 00:41:32 -0300
commit1b2d2002b275be684f29376148f2e2efdb8ca0d1 (patch)
treea9002b35c3095cea1e9618a2cf08a2ae33655de2 /PKGBUILD
downloadaur-1b2d2002b275be684f29376148f2e2efdb8ca0d1.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be13c4d9d46f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Pedro Henrique <pedro00dk@gmail.com>
+pkgname=overgrive
+pkgver=3.2.3
+pkgrel=1
+pkgdesc="OverGrive without any extra stuff required in
+https://www.thefanclub.co.za/overgrive/installation-instructions-arch-linux"
+arch=('x86_64')
+url="https://www.thefanclub.co.za/overgrive"
+license=("unknown")
+depends=(
+ libnotify libappindicator-gtk3 python2 python2-pyinotify python2-gobject python2-virtualenv
+)
+provides=("overgrive")
+conflicts=("overgrive")
+install="overgrive.install"
+changelog=
+source=(
+ "https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.2.3-0-any.pkg.tar.xz"
+)
+noextract=("overgrive-3.2.3-0-any.pkg.tar.xz")
+md5sums=("6d7cc554e39b6ea399ff88358a58eb78")
+prepare() {
+ tar --extract --file='./overgrive-3.2.3-0-any.pkg.tar.xz'
+ rm -- './overgrive-3.2.3-0-any.pkg.tar.xz'
+ sed --in-place -- \
+ 's+Exec=python2+Exec=/opt/thefanclub/overgrive/venv/bin/python2+g' \
+ './usr/share/applications/overgrive.desktop'
+}
+package() {
+ cp --recursive -- './opt/' './usr/' "${pkgdir}/"
+}