summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2019-08-14 21:51:56 -0400
committerJean Lucas2019-08-14 21:51:56 -0400
commit5a98afaf7ee23e5a64ca94587a9285888b5bad02 (patch)
treef5f012983cc362a017e7c82a4190ec93631b9731 /PKGBUILD
parent62856cdce596d07d9107264754a981bcaf657403 (diff)
downloadaur-oxy.tar.gz
Use a real pkgver; add gcc-libs as dep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 625c0fb71f4f..7a903cd7b437 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,18 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=oxy
-pkgver=3.0.0+105+g891cedf
+pkgver=3.0.0
_commit=891cedf8fd9945fbccd9e67f6644a80bc4963d81
-pkgrel=2
+pkgrel=1
pkgdesc='SSH-alike that uses the Noise protocol'
arch=(i686 x86_64)
url=https://github.com/oxy-secure/oxy
license=(BSD)
+depends=(gcc-libs)
makedepends=(git rust)
source=(git+$url#commit=$_commit)
sha512sums=('SKIP')
-pkgver() {
- cd oxy
- printf %s+%s+g%s $(grep '^version =' Cargo.toml | head -n1 | cut -d\" -f2 | sed s/-/+/) $(git rev-list --count HEAD) $(git describe --always)
-}
-
build() {
cd oxy
cargo build --release --locked