summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexis Polti2016-08-29 20:55:42 +0200
committerAlexis Polti2016-08-29 20:55:42 +0200
commit0a7fba422ea719ad0010bba8d568938ca20a6b5a (patch)
tree2af2802a77b76be7b81c45c6685fd0c146319fa7 /PKGBUILD
parentbe69010c73807326dff512399b674866795c036c (diff)
downloadaur-0a7fba422ea719ad0010bba8d568938ca20a6b5a.tar.gz
Temporary fix for file persmissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6fd5570083d..cab023e72fdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ozone
pkgver=2.18c
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc="Segger Ozone JLink debugger for Linux"
arch=('i686' 'x86_64')
@@ -36,10 +36,14 @@ package(){
cd ${srcdir}/Ozone*
+ # Make permissions right
+ find . -type d | xargs chmod a+rx
+ find . -type f | xargs chmod a+r
+
# Remove un-needed files
find . -name ".svn" | xargs rm -rf
- # Bulk copy everything except libs
+ # Bulk copy everything
cp --preserve=mode -r Ozone Plugins Doc Config Lib "${pkgdir}/opt/SEGGER/Ozone"
# Create links where needed