summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrey Rodionov2018-12-02 10:20:30 +0300
committerAndrey Rodionov2018-12-02 10:20:30 +0300
commit9201ad46bc1864e5d2973c57d8c26616a17f5454 (patch)
treec2715ed71781ce1be3ec845b4781838d746a2f4b /PKGBUILD
downloadaur-p7zip-zstd-codec.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62da9a7464a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=p7zip-zstd-codec
+pkgver=16.02
+pkgrel=1
+pkgdesc=" ZStandard codec for file archiver p7zip"
+arch=('x86_64')
+url="https://github.com/tehmul/p7zip-zstd"
+license=('LGPL')
+depends=('p7zip')
+makedepends_i686=('nasm')
+makedepends_x86_64=('yasm')
+source=("https://github.com/tehmul/p7zip-zstd/archive/7z16.02_zstd_1.1.4.tar.gz")
+sha256sums=('b46bd435af730d05df0c7c98f734e158cdc8e1499047c98923bbdab802f6afc2')
+
+build() {
+ cd "$srcdir/p7zip-zstd-7z16.02_zstd_1.1.4/p7zip_16.02"
+ make ZStd OPTFLAGS="$CFLAGS"
+}
+
+package() {
+ cd "$srcdir/p7zip-zstd-7z16.02_zstd_1.1.4/p7zip_16.02"
+ install -Dm755 "bin/Codecs/ZStd.so" "$pkgdir/usr/lib/p7zip/Codecs/ZStd.so"
+
+} \ No newline at end of file