summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleix Pol2022-11-11 19:34:50 +0100
committerAleix Pol2022-11-11 19:36:27 +0100
commitd027a1987ed5a689a2bd347e9a692a9a776c9293 (patch)
tree96ed0c3e0c3378c9180c377b2138ff6d9cba2720 /PKGBUILD
parent107b35a7bcaa95e94f4de39d246e50560e4bda5d (diff)
downloadaur-packagekit-git.tar.gz
Refresh scripts with the stable builds, only using git here
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD94
1 files changed, 59 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 450623aef11d..765aa4499e27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,70 @@
-pkgname='packagekit-git'
-pkgver=r4327.f537e89
-pkgrel=1
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Jonathan Conder <jonno.conder@gmail.com>
+
+pkgbase='packagekit-git'
+pkgname=('packagekit-git' 'libpackagekit-glib-git')
+pkgver=1.2.5
+pkgrel=2
pkgdesc='A system designed to make installation and updates of packages easier'
-arch=('i686' 'x86_64')
-url='http://www.packagekit.org/'
+arch=('x86_64')
+url='https://www.freedesktop.org/software/PackageKit/'
license=('GPL')
-depends=('dbus-glib' 'pacman>=5.0.0' 'polkit' 'shared-mime-info' 'sqlite')
-makedepends=('gobject-introspection' 'gtk-doc' 'intltool'
- 'networkmanager' 'bash-completion' 'vala' 'meson')
-optdepends=('networkmanager: detect connection status'
- 'bash-completion: command completion in bash')
-backup=('var/lib/PackageKit/transactions.db'
- 'etc/PackageKit/alpm.d/pacman.conf'
- 'etc/PackageKit/alpm.d/repos.list')
-source=("git+https://github.com/hughsie/PackageKit.git")
+makedepends=('polkit' 'sqlite' 'gobject-introspection' 'intltool'
+ 'bash-completion' 'vala' 'meson')
+options=('!emptydirs')
+validpgpkeys=('163EB50119225DB3DF8F49EA17ACBA8DFA970E17' # Richard Hughes <richard@hughsie.com>
+ 'EC60AABDF42AAE8FB062640480858FA38F62AF74') # Kalev Lember <klember@redhat.com>
+source=('0001-build-fix-overall-sysconfdir-handling-so-it-can-work.patch'
+ "git+https://github.com/PackageKit/PackageKit.git#branch=main")
replaces=(packagekit)
-md5sums=('SKIP')
+sha256sums=('f4dd7ce7dc2ef4a1b3d39a789d108c6e7f7791534b946b34a23b6553a9df3797'
+ SKIP)
+
+prepare() {
+ for _patch in *.patch; do
+ patch -d PackageKit -p1 < $_patch
+ done
+}
build() {
- cd "${srcdir}"
-
- arch-meson PackageKit --prefix=/usr \
- -Ddbus-sys=/usr/share/dbus-1/system.d \
- -Dgtk-doc=false \
- -Dlocal_checkout=false \
- -Dbrowser-plugin=false \
- -Dgstreamer-plugin=false \
- -Dgtk-module=false \
- -Dbash_command_not_found=false \
- -Dcron=false \
- -Ddaemon_tests=false \
- -Dpackaging_backend=alpm
- ninja
+ local _meson_options=(
+ -Dcron=false
+ -Ddbus_sys=/usr/share/dbus-1/system.d
+ -Dgstreamer_plugin=false
+ -Dgtk_doc=false
+ -Dgtk_module=false
+ -Dpackaging_backend=alpm
+ -Dsystemd=true
+ )
+
+ arch-meson "PackageKit" build "${_meson_options[@]}"
+
+ ninja -C build
}
-package() {
- cd "${srcdir}"
+package_packagekit-git() {
+ depends=('libpackagekit-glib' 'pacman>=6.0.0' 'polkit' 'sqlite')
+ optdepends=('bash-completion: command completion in bash')
+ backup=('var/lib/PackageKit/transactions.db'
+ 'etc/PackageKit/alpm.d/pacman.conf'
+ 'etc/PackageKit/alpm.d/repos.list')
+
+ # install directory with root owner, polkit group and
+ # correct permission
+ install -d -o root -g 102 -m 750 "${pkgdir}/usr/share/polkit-1/rules.d"
- # install directory with root owner, polkit group and
- # correct permission
- install -d -o root -g 102 -m 750 "${pkgdir}/usr/share/polkit-1/rules.d"
+ DESTDIR="$pkgdir" meson install -C build
+
+ # move away for libpackagekit-glib
+ mkdir -p libpackagekit/usr/{lib,share}
+ mv "$pkgdir"/usr/include/ libpackagekit/usr/
+ mv "$pkgdir"/usr/lib/{girepository-1.0,libpackagekit-glib2.so*,pkgconfig} libpackagekit/usr/lib/
+ mv "$pkgdir"/usr/share/{gir-1.0,vala}/ libpackagekit/usr/share/
+}
+package_libpackagekit-glib-git() {
+ pkgdesc='GLib library for accessing PackageKit'
+ depends=('glib2')
- DESTDIR="$pkgdir" meson install
+ mv libpackagekit/usr/ "$pkgdir"/
}