summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJörg Thalheim2015-10-13 22:54:13 +0200
committerJörg Thalheim2015-10-13 22:54:13 +0200
commitb3cf37ac817170d6486ea0c97f7720d81387d3de (patch)
treece8c7c7b49c6b1c3d168f3076c99e2304cd1c181 /PKGBUILD
downloadaur-pacnew-auto-git.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3852aff8f6d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Joan Rieu <joan.rieu@gmail.com>
+_pkgname=pacnew-auto
+pkgname=$_pkgname-git
+pkgver=r3.2b27b54
+pkgrel=1
+pkgdesc="Automatic pacman pacnew file merging using git rebase"
+arch=(any)
+url="https://github.com/joanrieu/pacnew-auto"
+license=('MIT')
+depends=(git)
+source=("git+https://github.com/joanrieu/$_pkgname")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ DESTDIR="$pkgdir/usr/bin/"
+ mkdir -p "$DESTDIR"
+ mv "$_pkgname/$_pkgname.sh" "$DESTDIR/$_pkgname"
+}