summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2024-05-12 00:48:12 +0100
committerWorMzy Tykashi2024-05-12 00:48:42 +0100
commit6c244e774684c119cce1e6e05f4b354cee5ab334 (patch)
treef8c58a98530ae57873964eb902ac3f00f567c35b /PKGBUILD
parent178257ca839a82945b2214039bb29c711bd59697 (diff)
downloadaur-6c244e774684c119cce1e6e05f4b354cee5ab334.tar.gz
Fix build failures with GCC>=14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6971d9f10aad..54f1baae6d6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,6 +3,7 @@
# Contributor: ilikenwf
# Contributor: American_Jesus
# Contributor: Mufflone
+# Contributor: switchnode
pkgname=palemoon
_repo=Pale-Moon
epoch=1
@@ -47,6 +48,10 @@ build() {
export MOZBUILD_STATE_PATH="${srcdir}/mozbuild"
export MOZCONFIG="${srcdir}/mozconfig"
export CPPFLAGS="${CPPFLAGS} -O2 -Wno-format-overflow"
+
+ # Fix build failures with GCC>=14
+ export CFLAGS="${CFLAGS} -Wno-implicit-int -Wno-incompatible-pointer-types -Wno-int-conversion"
+
./mach build
}