summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2023-08-09 20:35:42 +0100
committerWorMzy Tykashi2023-08-09 20:35:42 +0100
commit7d7ee8ef4591e54181643f874df4e7f47d762efb (patch)
tree72bbaaf8c8063f1ec2693cfac9d2fe359246dc9e /PKGBUILD
parent151f0d6c551c9b1f36797e3d585e61c42e119350 (diff)
downloadaur-7d7ee8ef4591e54181643f874df4e7f47d762efb.tar.gz
Include patch for libavcodec + binutils >= 2.41 build failure
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91755927eb11..149451a66c87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
# Contributor: artiom <a.mv at gmx dot fr>
# Contributor: ilikenwf
# Contributor: American_Jesus
+# Contributor: Mufflone
pkgname=palemoon
_repo=Pale-Moon
epoch=1
pkgver=32.3.1
# Commit ID can be found at https://repo.palemoon.org/MoonchildProductions/Pale-Moon/tags
_commit=093830a7af
-pkgrel=1
+pkgrel=2
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
url="https://www.palemoon.org/"
@@ -21,15 +22,18 @@ optdepends=('libpulse: PulseAudio audio driver'
'ffmpeg: various video and audio support')
source=(git+"https://repo.palemoon.org/MoonchildProductions/${_repo}?signed#commit=${_commit}"
git+"https://repo.palemoon.org/MoonchildProductions/UXP"
- mozconfig.in)
+ mozconfig.in
+ "mathops_operand_type_mismatch_for_shr.patch"::"https://git.videolan.org/?p=ffmpeg.git;a=patch;h=effadce6c756247ea8bae32dc13bb3e6f464f0eb")
validpgpkeys=('3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC'
'3059E09144F56804F0FBF4E126B40624BDBFD9F3')
sha1sums=('SKIP'
'SKIP'
- 'f682ada7d08dd59f86c95f42125148f9c629e4e8')
+ 'f682ada7d08dd59f86c95f42125148f9c629e4e8'
+ '0202b18ac4afb56d3a3e5033a9872cdc3e13b422')
sha256sums=('SKIP'
'SKIP'
- '333f547f048713b9900d5ba93477d239524a87b21a462e9ca8066dde27c3b0bd')
+ '333f547f048713b9900d5ba93477d239524a87b21a462e9ca8066dde27c3b0bd'
+ 'a50d7da9870a3fd801ad3a4d13d5c9b260acb094cf8bfa4afd95a54741173a7f')
prepare() {
sed 's#%SRCDIR%#'"${srcdir}"'#g' mozconfig.in > mozconfig
@@ -37,6 +41,9 @@ prepare() {
git submodule init
git config submodule.platform.url "${srcdir}/UXP"
git -c protocol.file.allow=always submodule update
+ # Apply patch for mathops_operand_type_mismatch_for_shr.patch
+ cd "platform/media/ffvpx"
+ patch -p1 -i "${srcdir}/mathops_operand_type_mismatch_for_shr.patch"
}
build() {