summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-09-26 10:56:43 -0600
committerMark Wagie2023-09-26 10:56:43 -0600
commit95c96ef5fa21ab009cfc67b79e4632a6a294512d (patch)
treeffc33889f970bf06dfbfb0b474a22d1066320468 /PKGBUILD
parent0c32f42164a08352f26598d63e6eb7332a5b3b8d (diff)
downloadaur-palette.tar.gz
drive-by fixes & improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24246daddb41..b124cc100118 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,42 @@
-# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
-# ex-Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer:
+# Contributor: Igor Dyatlov <dyatlov.igor@protonmail.com>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Nahuel Gomez Castro <nahual_gomca@outlook.com.ar>
pkgname=palette
pkgver=2.0.2
-_commit=01ce37b3e262574ad7594b5e5b906b7aacd2ab81
-pkgrel=1
-pkgdesc='Tool for viewing the GNOME color palette as defined by the design guidelines'
+pkgrel=2
+pkgdesc="Tool for viewing the GNOME color palette as defined by the design guidelines."
arch=('x86_64' 'aarch64')
-url='https://gitlab.gnome.org/World/design/palette'
+url="https://gitlab.gnome.org/World/design/palette"
license=('GPL3')
depends=('libadwaita')
makedepends=('git' 'meson' 'vala')
checkdepends=('appstream-glib')
-source=(
- "git+$url.git#commit=$_commit"
- "git+https://gitlab.gnome.org/Teams/Design/HIG-app-icons.git")
-b2sums=(
- 'SKIP'
- 'SKIP')
+_commit=01ce37b3e262574ad7594b5e5b906b7aacd2ab81 # tags/2.0.2^0
+source=("git+https://gitlab.gnome.org/World/design/palette.git#commit=${_commit}"
+ 'git+https://gitlab.gnome.org/Teams/Design/HIG-app-icons.git')
+sha256sums=('SKIP'
+ 'SKIP')
prepare() {
cd "${pkgname}"
git submodule init
- git config submodule.hig.url $srcdir/HIG-app-icons
- git submodule update
+ git config submodule.hig.url "$srcdir/HIG-app-icons"
+ git -c protocol.file.allow=always submodule update
}
build() {
- arch-meson "${pkgname}" build
+ arch-meson "$pkgname" build
meson compile -C build
}
check() {
- meson test -C build || :
+ meson test -C build --print-errorlogs
}
package() {
meson install -C build --destdir "$pkgdir"
+
+ ln -s /usr/bin/org.gnome.design.Palette "$pkgdir/usr/bin/$pkgname"
}