summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZeph332016-08-31 08:33:10 +0100
committerZeph332016-08-31 08:33:10 +0100
commitc2d64496d80b955cbcd5f68ce2a8b893841f9e22 (patch)
tree98ead5f40d15ecc1c02c8527ea436c1798a673fe /PKGBUILD
parent0c11afbce96f34b45ff2729dfc4a8ec585f5ff01 (diff)
downloadaur-c2d64496d80b955cbcd5f68ce2a8b893841f9e22.tar.gz
V4.1.4-2
Add pakage pamac-aur-tray-appindicator
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 24 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00eecdc37bc0..27ba35dd17e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,27 @@
# Contributor: Zeph <zeph33@gmail.com>
# Maintainer: Zeph <zeph33@gmail.com>
-
-pkgname=pamac-aur
+pkgbase=pamac-aur
+pkgname=('pamac-aur' 'pamac-aur-tray-appindicator')
pkgver=4.1.4
_pkgver=4.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="A Gtk3 frontend for libalpm"
arch=('any')
url="https://github.com/manjaro/pamac"
license=('GPL3')
depends=('glib2>=2.42' 'json-glib' 'libsoup' 'dbus-glib' 'polkit' 'vte3>=0.38' 'gtk3>=3.18'
'libnotify' 'desktop-file-utils' 'pacman>=5.0' 'gnutls>=3.4')
-optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
- 'lxsession: needed for authentification in Xfce, LXDE etc.'
- 'yaourt: needed for AUR support')
makedepends=('gettext' 'itstool' 'vala>=0.28')
-backup=('etc/pamac.conf')
-provides=('pamac')
-conflicts=('pamac')
options=(!emptydirs)
-install=pamac.install
source=("pamac-$pkgver-$pkgrel.tar.gz::https://github.com/manjaro/pamac/archive/v$_pkgver.tar.gz")
-sha256sums=('e4c9247156260c9b031c724cf002408580f508fa2adb64340b24e2a6c8071462')
+sha256sums=('edd0c0ee836be6c572f1bbaf5852324754ec9f574e003e6efe828ebeaaeaff65')
prepare() {
# adjust version string
cd "$srcdir/pamac-$_pkgver"
- sed -i -e "s|\"4.1.3\"|\"$pkgver-$pkgrel\"|g" src/transaction.vala
+ sed -i -e "s|\"4.1.4\"|\"$pkgver-$pkgrel\"|g" src/transaction.vala
# patches here
- # patch -Rp1 -i "$srcdir/revert-d840b05.patch"
}
build() {
@@ -39,9 +31,27 @@ build() {
make all
}
-package() {
+package_pamac-aur() {
+ optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
+ 'lxsession: needed for authentification in Xfce, LXDE etc.'
+ 'yaourt: needed for AUR support'
+ 'pamac-dev-tray-appindicator: tray icon for KDE')
+ backup=('etc/pamac.conf')
+ conflicts=('pamac')
+ provides=('pamac')
+ install=pamac.install
cd "$srcdir/pamac-$_pkgver"
make prefix="$pkgdir"/usr sysconfdir="$pkgdir"/etc install
}
+package_pamac-aur-tray-appindicator() {
+ pkgdesc="Tray icon using appindicator which feets better in KDE"
+ depends=('pamac-aur' 'libappindicator-gtk3')
+ provides=('pamac-tray-appindicator')
+ conflicts=('pamac-tray-appindicator')
+ cd "$srcdir/pamac-$_pkgver"
+ make use_appindicator=true
+ install -Dm755 src/pamac-tray-appindicator "$pkgdir"/usr/bin/pamac-tray-appindicator
+ install -Dm644 data/applications/pamac-tray-appindicator.desktop "$pkgdir"/etc/xdg/autostart/pamac-tray-appindicator.desktop
+}
# vim:set ts=2 sw=2 et: