summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcroxis2015-06-17 13:08:40 -0700
committercroxis2015-06-17 13:08:40 -0700
commit80d04dba25ffb6a3483d80000c38092fc0dd88c8 (patch)
treeb69bbbb19d3f5cf87fe74920cdfd837a59dd3185 /PKGBUILD
downloadaur-panda3d-runtime-git.tar.gz
Init commit
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..26a62c9e54b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Tucos <baspape@gmail.com>
+# Contributor: Hubert Grzeskowiak <arch at nemesis13 dot de>
+
+pkgname=panda3d-runtime-git
+pkgver=git
+pkgrel=1
+pkgdesc='3D engine with Python bindings. Runtime and web plugin.'
+url="http://www.panda3d.org"
+arch=('i686' 'x86_64')
+depends=('openssl' 'shared-mime-info' 'desktop-file-utils')
+makedepends=('python2' 'libpng' 'libjpeg')
+source=('panda3d::git+https://github.com/panda3d/panda3d.git')
+license=('BSD')
+md5sums=('SKIP')
+
+#prepare() {
+#cd $srcdir/$pkgname-$pkgver
+#patch -p1 -i $srcdir/patch.patch
+#}
+
+build() {
+ cd $srcdir/panda3d
+ python2 makepanda/makepanda.py --everything --runtime --distributor cmu --host https://runtime.panda3d.org/
+}
+
+package() {
+ cd $srcdir/panda3d
+ python2 makepanda/installpanda.py --destdir=$pkgdir --runtime --outputdir=built_cmu_rt --prefix=/usr
+ install -D -m755 $srcdir/panda3d/doc/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+}
+
+post_install() {
+ ldconfig
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+}
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+