summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQue Quotion2021-09-11 08:14:45 +0900
committerQue Quotion2021-09-11 08:14:45 +0900
commitddd9b37568a95a4af5199e85d38f2473b4784dbb (patch)
tree7d9c9b7233c60dc794c993dcba397f8a99c87665 /PKGBUILD
parent45b382368715dfe29291ec06bd5c3d0d8b56ca45 (diff)
downloadaur-pantheon-3d.tar.gz
Only csd-background of csd is required; various package reforms
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 234036dbf9c7..3ac50d1c8f3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,22 @@
# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
pkgname=pantheon-3d
-pkgver=6
+pkgver=7
pkgrel=1
pkgdesc='Pantheon 3d Session (replaces Gala with Compiz)'
arch=('any')
url='https://www.youtube.com/playlist?list=PLYkgvMpJJEaIOF5pDFk50eCPWYtkN70yC'
license=('GPL3')
groups=('pantheon-qq')
-depends=('compiz' 'pantheon-qq-common')
-source=(pantheon-compiz.{desktop,session})
+depends=('compiz' 'csd-background' 'pantheon-qq-common')
+source=(pantheon-compiz.{desktop,session}
+ 'cinnamon-settings-daemon-background-pantheon.desktop')
sha512sums=('4c7518fd824a6114ea615c223bd3af87130ac948448481e15ae3ff545eb1de482e4a175a9f6f1b15969a06f16284bddca97d8da228c09ade774c47da42496695'
- '8eda0a25ee90eabc7262e7f57d764457d651225ed841d5b1235b4792da5421132599e0b58eb41db7e8546a23791785c9a68f3b9860891d37ee5443daed4f17a3')
+ '8eda0a25ee90eabc7262e7f57d764457d651225ed841d5b1235b4792da5421132599e0b58eb41db7e8546a23791785c9a68f3b9860891d37ee5443daed4f17a3'
+ 'e3f549d9d0ef69b2b6595131758ca3f8a0cdb6f4c7a865e2b207853f878a14479902496952adc1963266c5369e5c69b4c272486b128c9b89c674ee1c1f626ac9')
package() {
- install -Dm655 {,"${pkgdir}"/usr/share/xsessions/}pantheon-compiz.desktop
- install -Dm655 {,"${pkgdir}"/usr/share/gnome-session/sessions/}pantheon-compiz.session
+ install -Dm644 {,"${pkgdir}"/usr/share/xsessions/}pantheon-compiz.desktop
+ install -Dm644 {,"${pkgdir}"/usr/share/gnome-session/sessions/}pantheon-compiz.session
+ install -Dm644 {"${srcdir}","${pkgdir}"/etc/xdg/autostart}/cinnamon-settings-daemon-background-pantheon.desktop
}
-