summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorron21382020-03-24 16:20:09 +0000
committerron21382020-03-24 16:20:09 +0000
commit557807183aeb4bc9144c46dac37508c1789185e2 (patch)
tree10691217d7e11db9d9a4af56f62d1806c96100d2 /PKGBUILD
downloadaur-pantum-p1000-p2000-p3000-m5100-m5200-ppd-driver.tar.gz
New name and description for the pantum-p2000-driver package
New name is pantum-p1000-p2000-p3000-m5100-m5200-ppd-driver. Desciption has also been changed. Changes meant to better describe the supported printers. The package with the new name has to conflicts('pantum-p2000-driver'). Both packages support the same printers, in exactly the same way. End of life of the old package is expected shortly.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9f3b38963e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Binary variant maintainer: < Ron Varburg AT yahoo com >
+# Contributor: Original submitter of pantum-p2000-driver:
+# Jack Kamm <jackkamm@gmail.com>
+
+pkgname=pantum-p1000-p2000-p3000-m5100-m5200-ppd-driver
+pkgver="1.00_1"
+pkgrel=4
+pkgdesc="PPDs, drivers, for Pantum P1000, P2000, P3000, M5100, M5200 printers"
+arch=('x86_64')
+url="http://global.pantum.com/global/"
+license=('proprietary')
+conflicts=('pantum-p2000-driver')
+depends=('cups')
+makedepends=('unzip')
+source=(
+ "http://global.pantum.com/global/wp-content/uploads/2016/01/Pantum-P2000-Series-Linux-DriverUbutun12.04V1.00-1.zip"
+)
+md5sums=('0024556a55eacef3d63ed4478ea1490d')
+
+build() {
+ cd $srcdir
+ mkdir -p ${pkgname}-${pkgver}
+ bsdtar -xf \
+ " Pantum 2000 Series Linux Driver (Ubutun12.04) V1.00/Pantum-0.3-1.${arch}.rpm" \
+ -C ${pkgname}-${pkgver}
+}
+
+package() {
+ cd ${pkgdir}
+ cp -a ${srcdir}/${pkgname}-${pkgver}/* .
+}
+
+# vim:set ts=2 sw=2 et: