summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFalko Galperin2023-10-16 13:33:20 +0200
committerFalko Galperin2023-10-16 13:33:20 +0200
commit872a23accd64a9a19a607e18d50d83334ecc6fe1 (patch)
tree57e22eba54dda19913efc7aca2f19c866d7de56a /PKGBUILD
parentfead4a4b24f0f27f48c5a7762712592ddfbb8221 (diff)
downloadaur-paper2remarkable.tar.gz
Update to upstream's 0.9.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6892658f4d0d..1b2a06a2be2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Falko Galperin <dr (dot) asasteghof (at) gmail (dot) com>
pkgname=paper2remarkable
-pkgver=0.9.11
+pkgver=0.9.12
pkgrel=1
pkgdesc="Easily download an academic paper and send it to a reMarkable."
arch=(any)
@@ -9,27 +9,27 @@ license=('MIT')
# Note: While we have the choice between qpdf and pdftk,
# python-pikepdf depends on qpdf anyway, so we use that here.
depends=('python>=3.6.0' 'qpdf' 'ghostscript' 'poppler' 'rmapi' 'python-pikepdf>=2.9.0'
-'python-beautifulsoup4>=4.8' 'python-html2text>=2020.1.16' 'python-markdown>=3.1.1'
-'python-pdfplumber>=0.5' 'python-yaml>=5.1' 'python-readability-lxml>=0.7.1'
-'python-regex>=2018.11' 'python-requests>=2.21' 'python-titlecase>=0.12'
-'python-unidecode>=1.1' 'python-weasyprint>=51', 'python-cloudscraper>=1.2.58'
-'python-pycryptodome' 'python-cssselect')
+ 'python-beautifulsoup4>=4.8' 'python-html2text>=2020.1.16' 'python-markdown>=3.1.1'
+ 'python-pdfplumber>=0.5' 'python-yaml>=5.1' 'python-readability-lxml>=0.7.1'
+ 'python-regex>=2018.11' 'python-requests>=2.21' 'python-titlecase>=0.12'
+ 'python-unidecode>=1.1' 'python-weasyprint>=51'
+ 'python-pycryptodome' 'python-cssselect')
makedepends=('python-setuptools')
optdepends=('python-readabilipy: Improves output of web articles')
changelog=$pkgname.changelog.md
install=$pkgname.install
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=("b032adeabf72d04b3dd4bf8f91c305850fd865b3eabc2efaf0ae2f6ea23b6be3")
+sha256sums=("b2280295ddc9adf69d9082189e9d4c1235bea63ba2143c80ebd0ec5805249b59")
build() {
- cd "$pkgname-$pkgver/"
- python setup.py build
+ cd "$pkgname-$pkgver/"
+ python setup.py build
}
package() {
- cd "$pkgname-$pkgver/"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- # move man page to directory specified by FHS guidelines
- mkdir -p "$pkgdir/usr/share/"
- mv "$pkgdir/usr/man" "$pkgdir/usr/share/man"
+ cd "$pkgname-$pkgver/"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ # move man page to directory specified by FHS guidelines
+ mkdir -p "$pkgdir/usr/share/"
+ mv "$pkgdir/usr/man" "$pkgdir/usr/share/man"
}