summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-02-25 08:39:05 -0700
committerMark Wagie2022-02-25 08:39:05 -0700
commit266d78bfc97c4c43d3dc8146c178370e842375fa (patch)
tree05d8fe903b8bd681a61563800ebd3dda7948b87a /PKGBUILD
parenta1b4072fa1ed92b6531697272386ad7c29e76208 (diff)
downloadaur-papirus-folders-gui.tar.gz
switch to Qt6, add polkit auth agents to optdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a046af8d534..f93f30db3ad1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,22 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: ItzSelenux
pkgname=papirus-folders-gui
pkgver=1.5
-pkgrel=1
+pkgrel=2
pkgdesc="A graphical user interface for papirus-folders"
url="https://github.com/ItzSelenux/papirus-folders-gui"
arch=('x86_64')
license=('GPL2')
-depends=('papirus-folders' 'polkit' 'qt5-base')
-makedepends=('cmake' 'qt5-tools')
+depends=('papirus-folders' 'qt6-base')
+makedepends=('cmake' 'qt6-tools')
+optdepends=('lxqt-policykit: option for polkit authentication agent'
+ 'lxsession-gtk3: option for polkit authentication agent'
+ 'mate-polkit: option for polkit authentication agent'
+ 'polkit-gnome: option for polkit authentication agent'
+ 'polkit-kde-agent: option for polkit authentication agent')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
sha256sums=('c24246fc1f8af443e9f0e8f3e8138af4ac39caaa62ed05f22438039592ed0c0a')
-
+
build() {
cmake -B build -S "$pkgname-$pkgver" \
-DCMAKE_BUILD_TYPE='None' \
@@ -17,10 +24,10 @@ build() {
-Wno-dev
cmake --build build
}
-
+
package() {
install -Dm755 "build/$pkgname" -t "$pkgdir/usr/bin"
-
+
cd "$pkgname-$pkgver"
install -Dm644 papirus.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
install -Dm644 folder-logo.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/$pkgname.svg"