summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoel Grunbaum2021-11-09 13:18:05 +1100
committerJoel Grunbaum2021-11-09 13:18:05 +1100
commit9054fbb29e8d549ac4b028a1dd61b5822928c3b3 (patch)
tree72ba52170fa567105751788a0a0a1ce90f103d01 /PKGBUILD
parentd54809ae85b6515bc6247a1d9e8312889b41aa88 (diff)
downloadaur-pappl-git.tar.gz
updated pkgbuild to match repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3f20ef62137..502827d829eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Joel Grunbaum <joel@joelg.net>
_pkgname=pappl
pkgname=$_pkgname-git
-pkgver=r512.cae4783
+pkgver=r914.d42115a
pkgrel=1
-pkgdesc="PAPPL - Printer Application Framework"
+pkgdesc="a simple C-based framework/library for developing CUPS Printer Applications"
arch=('x86_64')
-url="https://www.msweet.org/pappl/index.html"
-license=('Apache')
-depends=()
-makedepends=('git' 'avahi' 'libcups' 'gnutls' 'libjpeg-turbo' 'pam' 'libpng' 'zlib' 'libusb')
+url="https://www.msweet.org/pappl/"
+license=('Apache' 'custom')
+depends=('libcups' 'libjpeg-turbo' 'pam')
+makedepends=('git')
+provides=('pappl')
+conflicts=('pappl')
source=('git+https://github.com/michaelrsweet/pappl.git')
md5sums=('SKIP')
@@ -19,6 +21,7 @@ pkgver() {
build() {
cd "$_pkgname"
+ export DSOFLAGS=${LDFLAGS}
./configure --prefix=/usr
make
}
@@ -26,4 +29,8 @@ build() {
package() {
cd "$_pkgname"
make DESTDIR="$pkgdir/" install
+
+ install -Dm755 testsuite/testpappl -t "$pkgdir/usr/bin"
+ install -Dm644 doc/* -t "$pkgdir/usr/share/doc/$pkgname"
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" {LICENSE,NOTICE}
}