summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-03-21 14:41:30 -0600
committerMark Wagie2024-03-21 14:41:30 -0600
commitb6c9253f042f6379febbe094ecf6329cfd2b8ac7 (patch)
tree56b1c90ecccc1c7feefa4d0024fb64b4181410bb /PKGBUILD
parent470394b7e95467d0eda7370a5f71de04a98dd757 (diff)
downloadaur-parrot.tar.gz
enable LTO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c6a6d028ac8..15dfc4507044 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer: DanCodes <dan@dancodes.online>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+# Co-Maintainer: DanCodes <dan@dancodes.online>
pkgname=parrot
pkgver=1.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="A Rust-based GUI in Tauri for pacman using the wrapper paru."
arch=('x86_64')
url="https://github.com/dan-online/parrot"
license=('MIT')
depends=('gtk3' 'webkit2gtk')
makedepends=('cargo' 'node-gyp' 'yarn')
-options=('!lto')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
sha256sums=('32c7a8b20a908e0d57de4c7ff503af117c34b1b93f76937daa3380edd3116882')
@@ -31,6 +31,7 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
+ CFLAGS+=" -ffat-lto-objects"
export YARN_CACHE_FOLDER="$srcdir/yarn-cache"
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable