summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDamien Robert2020-06-01 14:22:30 +0200
committerDamien Robert2020-06-01 14:22:30 +0200
commit646e3dcd161b16cfc165576a2076af5d41dd8e88 (patch)
tree61f34a3bbeb540bd60fccad7f0df8bffba04fe64 /PKGBUILD
parent45b857ea0c2f62ccc86d7e210113066a3460ff9e (diff)
downloadaur-path-extractor.tar.gz
upgpkg: uni 1.1.1-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 266857e5dc14..0af7ec4725d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=path-extractor
pkgver=0.2.0
-pkgrel=3
+pkgrel=4
pkgdesc='A unix filter which outputs the filepaths found in stdin'
arch=('x86_64')
repo="github.com/edi9999/$pkgname"
@@ -21,12 +21,11 @@ prepare() {
}
build() {
+ export CGO_LDFLAGS="$LDFLAGS"
+ export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
export GOPATH="$srcdir/gopath"
cd "$gopkg"
- go install \
- -trimpath \
- -ldflags "-extldflags ${LDFLAGS}" \
- -v ./...
+ go install -v ./...
}
# Skip check, they don't pass