summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsnemc2024-03-07 20:26:58 +0800
committersnemc2024-03-07 20:26:58 +0800
commit2b19bc27deea20b5b4fa0d2e7c6ef0eb2f641d4c (patch)
tree9ad4a00782c02c39cac76e915fb29ebc42c56527 /PKGBUILD
downloadaur-pauser.tar.gz
提交pauser包
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0cc7729c75d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: snemc <3112671039@qq.com>
+pkgname=pauser
+pkgver=0.0.1
+pkgrel=1
+epoch=
+pkgdesc="一个开源的检测程序运行算法问题的耗时和内存占用的小工具."
+arch=('x86_64')
+url="https://github.com/jswysnemc/ConsolePauserPlusPlus"
+license=('GPL-3.0-only')
+depends=("glibc")
+makedepends=("git" "make" "gcc" "glibc")
+source=("$pkgname-$pkgver::git+https://github.com/jswysnemc/ConsolePauserPlusPlus.git")
+noextract=("${source[@]##*/}")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 ./build/bin/pauser "$pkgdir"/usr/bin/pauser
+}