summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSven-Hendrik Haase2018-09-08 23:21:17 +0200
committerSven-Hendrik Haase2018-09-08 23:21:17 +0200
commit973cc93ce11847a38765ce70cfbb7d2757b6bde6 (patch)
tree8f44098596c49d5f1476e191803d75604adccb37 /PKGBUILD
downloadaur-pax-rs.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2307c6ebb02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
+
+pkgname=pax-rs
+_pkgname=pax
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="The fastest JavaScript bundler in the galaxy."
+arch=('x86_64')
+url="https://github.com/nathan/pax"
+license=(MIT)
+makedepends=(cargo)
+source=(https://github.com/nathan/pax/archive/pax-v${pkgver}.tar.gz)
+sha512sums=('a9e32539ab661f93772a5c5c9a07c90cc23097fa119f88c909cc4b2288b95f910ed94c9af35365c44a5c2be79ca1674d81f96abf8d0cbddaf615e7654928c5e5')
+
+build() {
+ cd "$srcdir/$_pkgname-$_pkgname-v$pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$_pkgname-v$pkgver"
+
+ install -Dm755 target/release/px "$pkgdir"/usr/bin/px
+}
+
+# vim:set ts=2 sw=2 et: