summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKino2024-05-04 22:07:22 +0800
committerKino2024-05-04 22:07:22 +0800
commitad058998aa119e2670c69bdd7af3a0330d36f06b (patch)
treef4343dd0487128467dd90fb8a7d2cb36c35375bf /PKGBUILD
parent8ceabc68a444cb65b3f9f1d0978ef88b6d32aa6c (diff)
downloadaur-pcl.tar.gz
upgpkg: 1.14.1-2; enable simulation, disable outofcore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 114f198f1c73..3f848c80bd7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,14 @@
pkgname=pcl
pkgver=1.14.1
-pkgrel=1
-pkgdesc="A comprehensive open source library for n-D Point Clouds and 3D geometry processing"
+pkgrel=2
+pkgdesc="A standalone, large scale, open project for 2D/3D image and point cloud processing"
arch=('x86_64' 'i686')
url='https://www.pointclouds.org'
license=('BSD')
-depends=('boost' 'eigen' 'flann' 'vtk' 'libpcap' 'libpng' 'libusb' 'libx11')
+depends=('boost' 'eigen' 'flann' 'freeglut' 'glew' 'vtk' 'libpcap' 'libpng' 'libusb')
optdepends=('cuda' 'openmp' 'openni2' 'qhull')
-makedepends=('adios2' 'cgns' 'cli11' 'cmake' 'fmt' 'glew' 'gl2ps' 'libharu' 'liblas' 'libxcursor'
+makedepends=('adios2' 'cgns' 'cli11' 'cmake' 'fmt' 'gl2ps' 'libharu' 'liblas' 'libxcursor'
'netcdf' 'openvr' 'ospray' 'pdal' 'python-mpi4py' 'qt5-base' 'utf8cpp' 'verdict')
checkdepends=('gtest')
source=("https://github.com/PointCloudLibrary/pcl/archive/${pkgname}-${pkgver}.tar.gz")
@@ -31,6 +31,8 @@ build() {
-DCMAKE_INSTALL_PREFIX='/usr' \
-DWITH_QT='QT5' \
-DBUILD_surface_on_nurbs=ON \
+ -DBUILD_outofcore=OFF \
+ -DBUILD_simulation=ON \
-DBUILD_global_tests=ON \
-Wno-dev
cmake --build build