summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaul Werther2023-01-28 11:50:33 +0100
committerPaul Werther2023-01-28 11:50:33 +0100
commitaad45e53e3572fd08ea8963eb73ac2a8e9a69c2c (patch)
tree630e5104c7f0fd78bc0744635ba6ad0491b097be /PKGBUILD
downloadaur-pdtm-bin.tar.gz
add pdtm-bin to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cc257681588
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: FLX (Paul Werther) <flx@evait.de>
+pkgname=pdtm-bin
+_pkgname=pdtm
+pkgver=0.0.3
+pkgrel=1
+pkgdesc='pdtm is a simple and easy-to-use golang based tool for managing open source projects from ProjectDiscovery'
+arch=('x86_64' 'armv6h' 'armv7h' 'aarch64')
+url='https://github.com/projectdiscovery/pdtm'
+license=('MIT')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=('glibc')
+source=("https://github.com/projectdiscovery/pdtm/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.zip")
+md5sums=('afe73ee850288f19892a791287406f4d')
+
+package() {
+ install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin/"
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}"
+}