summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Rogoża2021-02-15 23:34:51 +0100
committerPiotr Rogoża2021-02-15 23:34:51 +0100
commita240b5ed325852d7a420fd7158669270375c8336 (patch)
treef8ef71caa350d4920e6d5d6db16ef7ebac30a1a9 /PKGBUILD
parent4058c494f078c8f73792544b3c651c676fcb80ca (diff)
downloadaur-perl-config-std.tar.gz
Upgraded to 0.903
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 19 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b454eb4355df..faafad58a8a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,13 @@
-# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
-# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# Contributor: <firmicus ατ gmx δοτ net>
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
_author=B/BR/BRICKER
_perlmod=Config-Std
pkgname=perl-config-std
-pkgver=0.901
+pkgver=0.903
pkgrel=1
pkgdesc="Config::Std - Load and save configuration files in a standard format"
arch=('any')
-url="http://search.cpan.org/dist/Config-Std"
+url="https://metacpan.org/release/Config-Std"
license=('GPL' 'PerlArtistic')
depends=(perl-class-std)
makedepends=(perl-class-std)
@@ -22,51 +20,35 @@ perl-config-std-keyval
)
options=(!emptydirs)
source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('b7709ff663bd279d264ab9c2f51e9e9588479a3367a8c4cfc18659c2a11480fe')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
build(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- /usr/bin/perl Makefile.PL
+ if [ -f Makefile.PL ]; then
+ perl Makefile.PL
make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- /usr/bin/perl Build.PL
- perl Build
+ else
+ perl Build.PL
+ ./Build
fi
}
check(){
# https://rt.cpan.org/Public/Bug/Display.html?id=85956
- return 0
+# return 0
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
+ if [ -f Makefile.PL ]; then
make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
+ else
+ ./Build test
fi
}
package(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
fi
-
- # remove perllocal.pod and .packlist
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
-md5sums=('e18f550af8d402e245edb7927c73fd4c')