summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Guillaumin2018-09-23 16:07:49 -0700
committerNicolas Guillaumin2018-09-23 16:07:49 -0700
commit57d2939476a2c896852105cebf0b8a5e7049e805 (patch)
treeb83efb822ab1f6c11ff6b97ab6274fe44dd3d5a1 /PKGBUILD
downloadaur-perl-digest-bcrypt.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ac430912603
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer : Nicolas Guillaumin <nicolas plus archlinux at guillaumin dot me>
+pkgname=perl-digest-bcrypt
+pkgver=1.209
+pkgrel=1
+pkgdesc='Perl interface to the bcrypt digest algorithm'
+_dist=Digest-Bcrypt
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('PerlArtistic')
+depends=(perl)
+makedepends=()
+options=('!emptydirs' purge)
+source=("https://cpan.metacpan.org/authors/id/C/CA/CAPOEIRAB/$_dist-$pkgver.tar.gz")
+md5sums=(b03529a1cfc31c04a66d7736b4ca4003)
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}