summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThiago L. A. Miller2018-09-08 00:00:44 -0300
committerThiago L. A. Miller2018-09-08 00:00:44 -0300
commit69ed497a0ab372d29afc8f17d2df049563139403 (patch)
treedd87cc91137d2806fb20d3aabc9a4ae82f43ff8e /PKGBUILD
parent9321db8af66a4545c64d8daf44cbea908119ffac (diff)
downloadaur-perl-dist-zilla-plugin-checkchangelog.tar.gz
Update to version 0.05
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 485e728d37d2..4dc5b0496f43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
-
-pkgname='perl-dist-zilla-plugin-checkchangelog'
-pkgver='0.01'
-pkgrel='1'
+# Maintainer: Thiago L. A. Miller <thiago_leisrael@hotmail.com>
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+_distname=Dist-Zilla-Plugin-CheckChangeLog
+pkgname=perl-dist-zilla-plugin-checkchangelog
+pkgver=0.05
+pkgrel=1
pkgdesc="Dist::Zilla with Changes check"
arch=('any')
+url="http://search.cpan.org/dist/$_distname"
license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=('perl-dist-zilla>=1.007')
+depends=('perl>=5.004'
+ 'perl-dist-zilla>=6.005'
+ 'perl-path-class>=0'
+ 'perl-pod-markdown>=0')
makedepends=()
-url='http://search.cpan.org/dist/Dist-Zilla-Plugin-CheckChangeLog'
-source=('http://search.cpan.org/CPAN/authors/id/F/FA/FAYLAND/Dist-Zilla-Plugin-CheckChangeLog-0.01.tar.gz')
-md5sums=('a694b9c3ff185f6a5c06b851af9034cf')
-sha512sums=('d974eb4994c9d4795a1256c6ffa3a9c9c7f3e30200bf9dfe9610f4a6b75a6a6642630b56304d9ba4ae2fce92a6a8f5d114d90322e4fdc1d655779d2bcb6c6585')
-_distdir="Dist-Zilla-Plugin-CheckChangeLog-0.01"
+checkdepends=('perl-pod-coverage>=0'
+ 'perl-pod-coverage-trustpod>=0'
+ 'perl-test-exception>=0.43'
+ 'perl-test-pod>=0'
+ 'perl-test-pod-coverage>=0')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/F/FA/FAYLAND/$_distname-$pkgver.tar.gz")
+md5sums=('1c0c8e2c7887d2dbbbd760bed69cbed4')
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -23,23 +29,22 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
make install
-
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}