summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThiago L. A. Miller2018-09-08 00:22:40 -0300
committerThiago L. A. Miller2018-09-08 00:22:40 -0300
commitdf2dc0b1d06543edec37e48ffd06b7f6f1c82f3f (patch)
tree0e0572bc19e0ca094e10c324696c0268f2e1c8b3 /PKGBUILD
parent702abfce937d7bb22c0ed0ca0aa25aba656ca8cc (diff)
downloadaur-perl-dist-zilla-plugin-checkchangeshascontent.tar.gz
Update to version 0.011
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e44d755bfb1b..1f4496751c2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
-
-pkgname='perl-dist-zilla-plugin-checkchangeshascontent'
-pkgver='0.006'
-pkgrel='1'
+# Maintainer: Thiago L. A. Miller <thiago_leisrael@hotmail.com>
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+_distname=Dist-Zilla-Plugin-CheckChangesHasContent
+pkgname=perl-dist-zilla-plugin-checkchangeshascontent
+pkgver=0.011
+pkgrel=1
pkgdesc="Ensure Changes has content before releasing"
arch=('any')
+url="http://search.cpan.org/dist/$_distname"
license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=('perl-capture-tiny' 'perl-dist-zilla>=2.100950' 'perl-file-pushd' 'perl-moose>=0.99' 'perl-namespace-autoclean>=0.09' 'perl-path-class' 'perl-try-tiny')
+depends=('perl>=5.006'
+ 'perl-capture-tiny>=0'
+ 'perl-data-section>=0.200002'
+ 'perl-dist-zilla>=6'
+ 'perl-moose>=2'
+ 'perl-path-tiny>=0'
+ 'perl-sub-exporter-formethods>=0'
+ 'perl-namespace-autoclean>=0.28')
makedepends=()
-url='http://search.cpan.org/dist/Dist-Zilla-Plugin-CheckChangesHasContent'
-source=('http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Dist-Zilla-Plugin-CheckChangesHasContent-0.006.tar.gz')
-md5sums=('3b38207e57f91a1b2d51cc890cc2fa6c')
-sha512sums=('48be216ca008333fd4ade7f1aae2292c7ee73ec245e661bd6dfb98006b1ba290106bee8f36a2e66b41bc5aff87110d084853f7e9d6e9dfe82c2c5fa7d9aa230a')
-_distdir="Dist-Zilla-Plugin-CheckChangesHasContent-0.006"
+checkdepends=('perl-test-fatal>=0')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/$_distname-$pkgver.tar.gz")
+md5sums=('9d9c660042b546304486f77121df339a')
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -23,23 +29,22 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
make install
-
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}