summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMilosD2015-07-05 11:39:29 +0200
committerMilosD2015-07-05 11:39:29 +0200
commit4d8d3e4d9e9f6e487b86d4ddc8964c9d156bec16 (patch)
treeda2589024ea67a58778c3d327fab9997fccd9f9e /PKGBUILD
downloadaur-perl-event-rpc.tar.gz
First perl-event-rpc push
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b3bed0037e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: gls < ghostlovescorebg at gmail dot com >
+
+pkgname=perl-event-rpc
+pkgver=1.05
+pkgrel=1
+pkgdesc="Event based transparent Client/Server RPC framework."
+_dist=Event-RPC
+url="http://search.cpan.org/~jred/${_dist}-${pkgver}"
+license="GPL PerlArtistic"
+depends=('perl')
+arch=('any')
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/J/JR/JRED/${_dist}-${pkgver}.tar.gz")
+md5sums=('fd6e257b922dea322f72efae8a756592')
+
+build() {
+
+ cd ${srcdir}/${_dist}-${pkgver}
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+
+}
+
+check() {
+
+ cd ${srcdir}/${_dist}-${pkgver}
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+
+}
+
+package() {
+
+ cd ${srcdir}/${_dist}-${pkgver}
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+
+}