summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Rogoża2023-11-07 22:42:18 +0100
committerPiotr Rogoża2023-11-07 22:42:18 +0100
commit55f1fca606a6770ddf6712d24cc6816b304aaa55 (patch)
tree9110ddb5c482724f9d566065469963430eeb5b34 /PKGBUILD
parentaecd66bd672e4b56b79aff54d46ea6e50ef7de00 (diff)
downloadaur-perl-file-find-rule-vcs.tar.gz
Update to 1.09
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 18 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99d7de893831..0114cba8f674 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,42 @@
-# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
-# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-
pkgname=perl-file-find-rule-vcs
-pkgver=1.08
+pkgver=1.09
pkgrel=1
-_author="A/AD/ADAMK"
+_author=E/ET/ETHER
_perlmod="File-Find-Rule-VCS"
pkgdesc="File::Find::Rule::VCS - Exclude files/directories for Version Control Systems"
arch=('any')
-url="http://search.cpan.org/dist/File-Find-Rule-VCS/"
+url="https://metacpan.org/release/File-Find-Rule-VCS/"
license=('GPL' 'PerlArtistic')
depends=('perl>=5.10.0')
options=(!emptydirs)
source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('43c798bff0a1f6ac196cfa0f28eddac768954df2d02a04d01974a8fafeafbb49')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
build(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- /usr/bin/perl Makefile.PL
+ if [ -f Makefile.PL ]; then
+ perl Makefile.PL
make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- /usr/bin/perl Build.PL
- perl Build
+ else
+ perl Build.PL
+ ./Build
fi
}
check(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
+ if [ -f Makefile.PL ]; then
make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
+ else
+ ./Build test
fi
}
package(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
fi
-
- # remove perllocal.pod and .packlist
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
-
-md5sums=('2e4031812450dc6510270cf88834d80c')