summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Guillaumin2018-09-04 12:52:30 -0700
committerNicolas Guillaumin2018-09-04 12:52:30 -0700
commit096f98e85367d4fac080f636d7ac8083f6bb7844 (patch)
treefd6a4c06de2957af26120f0d1c5b816f86f0b608 /PKGBUILD
downloadaur-perl-file-lockf.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18b75bcae0a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer : Nicolas Guillaumin <nicolas plus archlinux at guillaumin dot me>
+pkgname=perl-file-lockf
+pkgver=0.25
+pkgrel=1
+pkgdesc='Perl module interface to the lockf system call'
+_dist=File-Lockf
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('Unknown')
+depends=(perl)
+makedepends=()
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/P/PH/PHENSON/$_dist-$pkgver.tar.gz")
+md5sums=(3c6b8ca40caa1b3975f5b7567d91d6f1)
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}