summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRubenKelevra2016-07-05 17:23:13 +0200
committerRubenKelevra2016-07-05 17:23:13 +0200
commitc48bb3069d74b37035637cbd749144c953988d8e (patch)
treed019b2df5489f0df99909ab09c152e807a3e51cb /PKGBUILD
downloadaur-perl-html-rewriteattributes.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eff206145361
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+# Maintainer: Ruben Kelevra <ruben@vfn-nrw.de>
+
+pkgname='perl-html-rewriteattributes'
+_cpanname='HTML-RewriteAttributes'
+pkgver='0.05'
+pkgrel=1
+pkgdesc='Concise attribute rewriting'
+arch=('any')
+url="http://search.cpan.org/~tsibley/$_cpanname-$pkgver/"
+license=(
+ 'GPL'
+ 'PerlArtistic'
+)
+depends=(
+ 'perl-regexp-common'
+ 'perl>=5.5.0'
+)
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/T/TS/TSIBLEY/$_cpanname-$pkgver.tar.gz")
+sha256sums=('1808ec7cdf40d2708575fe6155a88f103b17fec77973a5831c2f24c250e7a58c')
+
+# Function to change to the working directory and set
+# environment variables to override undesired options.
+prepareEnvironment() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ export \
+ PERL_MM_USE_DEFAULT=1 \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+}
+
+build() {
+ prepareEnvironment
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ prepareEnvironment
+ make test
+}
+
+package() {
+ prepareEnvironment
+ make install
+
+ # Remove "perllocal.pod" and ".packlist".
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}