summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2020-11-27 15:59:38 +0100
committerKrzysztof AS (3ED)2020-11-27 15:59:38 +0100
commitc7c3b6c9b07b3ee1bd97802cd182319f670fe45a (patch)
treede3544bd4ffa27c5231673769699e2934f2e7880 /PKGBUILD
downloadaur-perl-menlo.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ada7b6bb373
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Mantainer: 3ED <krzysztof1987 at gmail dot com>
+#
+pkgname=perl-menlo
+_lastauthor=M/MI/MIYAGAWA
+_pkgname=Menlo
+pkgver=1.9019
+pkgrel=1
+pkgdesc='A CPAN client'
+arch=('any')
+license=('PerlArtistic' 'GPL')
+depends=(
+ perl-capture-tiny
+ perl-class-tiny
+ perl-cpan-common-index
+ perl-cpan-distnameinfo
+ perl-cpan-meta
+ perl-cpan-meta-check
+ perl-extutils-config
+ perl-extutils-helpers
+ perl-extutils-installpaths
+ perl-file-which
+ perl-json-pp
+ perl-local-lib
+ perl-module-cpanfile
+ perl-parse-pmfile
+ perl-string-shellquote
+ perl-uri
+)
+url="http://search.cpan.org/dist/${_pkgname}/"
+source=(http://search.cpan.org/CPAN/authors/id/${_lastauthor}/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('3b573f68e7b3a36a87c860be258599330fac248b518854dfb5657ac483dca565')
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ perl Makefile.PL
+ make
+}
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make test
+}
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make install
+}
+