summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan-Erik Rediger2015-06-09 16:15:31 +0200
committerJan-Erik Rediger2015-06-09 16:15:31 +0200
commit848c400f38b377251bc7257a192baa8b2e3a68bf (patch)
treee4384473698416178f7fe688e8fe056f3d8f0789 /PKGBUILD
downloadaur-perl-net-sdp.tar.gz
First commit in new AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d2226846272
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jan-Erik Rediger <badboy at archlinux dot us>
+
+pkgname=perl-net-sdp
+_cpanname=Net-SDP
+pkgver=0.07
+pkgrel=2
+pkgdesc="Net::SDP is an SDP (Session Description Protocol) parser and generator."
+arch=('any')
+url="http://search.cpan.org/~njh/${_cpanname}/"
+license=('GPL')
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/N/NJ/NJH/${_cpanname}-${pkgver}.tar.gz)
+md5sums=('bb70cb8ebb7ca57c20ac134ac4499e66')
+
+build() {
+ cd "$srcdir/${_cpanname}-${pkgver}"
+ # install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/${_cpanname}-${pkgver}"
+ make install DESTDIR="$pkgdir/"
+}
+
+# vim:set ts=2 sw=2 sts=2 et: