summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoritz Bunkus2024-03-26 20:11:59 +0100
committerMoritz Bunkus2024-03-26 20:12:23 +0100
commitd70ac5e487938d73e4cdf012901cc022b6608c90 (patch)
treeb84779f20350a77b300247e890eed248bafc7ae0 /PKGBUILD
parent815c3bb0e1169a9b508b68d3999da3a72b914e25 (diff)
downloadaur-perl-net-sip.tar.gz
add patch for exiting from functions properly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70a2fb6aac67..963e9f594726 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
pkgname="perl-net-sip"
pkgver="0.836"
-pkgrel="1"
+pkgrel="2"
pkgdesc="SIP (Voice Over IP, RFC3261) packet handling"
arch=("any")
license=("PerlArtistic")
options=("!emptydirs")
depends=("perl-net-dns")
url="https://github.com/noxxi/p5-net-sip"
-source=("https://cpan.metacpan.org/authors/id/S/SU/SULLR/Net-SIP-${pkgver}.tar.gz")
-sha512sums=('a87096ffaac2c87f252f7d06524398341e5f3a674745fa7a1613aeb087d29edcb933c28fce750b0ce77f54a83a91c6ffea8c95743c97370368c4e83af98da8d9')
+source=("https://cpan.metacpan.org/authors/id/S/SU/SULLR/Net-SIP-${pkgver}.tar.gz"
+ '5c18a54935955903ada55096115c347e08118a75.patch')
+sha512sums=('a87096ffaac2c87f252f7d06524398341e5f3a674745fa7a1613aeb087d29edcb933c28fce750b0ce77f54a83a91c6ffea8c95743c97370368c4e83af98da8d9'
+ '167074ffc428fc0a92b81779f527e0d7500a22eb97bce3a0bc00b4fd0c242ae01ca7b1a859dffcc61616ba80b5cb7827d0f8695620005ee5f33cedd1db10432d')
prepare_environment() {
export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -23,6 +25,9 @@ prepare_environment() {
build() {
prepare_environment
+
+ patch -p1 < "$srcdir/5c18a54935955903ada55096115c347e08118a75.patch"
+
/usr/bin/perl Makefile.PL
make
}